블로그 이미지
Every unexpected event is a path to learning for you.

카테고리

분류 전체보기 (2366)
Unity3D (587)
Programming (473)
Unreal (4)
Gamebryo (56)
Tip & Tech (191)
협업 (36)
3DS Max (3)
Game (12)
Utility (117)
Etc (92)
Link (31)
Portfolio (19)
Subject (90)
iOS,OSX (38)
Android (13)
Linux (5)
잉여 프로젝트 (2)
게임이야기 (1)
Memories (20)
Interest (37)
Thinking (37)
한글 (26)
PaperCraft (5)
Animation (408)
Wallpaper (2)
재테크 (19)
Exercise (3)
나만의 맛집 (3)
냥이 (10)
육아 (16)
Total1,365,188
Today16
Yesterday373
Statistics Graph

달력

« » 2020.1
      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31  

공지사항

태그목록

Windows7 64bit

Unity 2018.4.13f1

Firebase 6.9.0

 

Firebase 6.9.0 넣고 나온 또 다른 빌드 에러..


CommandInvokationFailure: Gradle build failed. 

...

stderr[

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':packageRelease'.
> 1 exception was raised by workers:
  java.io.UncheckedIOException: java.io.IOException: Failed to obtain compression information for entry

 


해결책은 아래와 같다.

Minify-Release/Debug가 기본 None인데, 업데이트 되면서 값을 넣어야 되나보다.

Proguard 이야기도 있긴한데, 우선 아래 보이는대로 Gradle (Experimental) 로 바꾸니 빌드가 잘 된다.

 


 

Someone in the thread from unity forum finally posted a working solution. I'm gonna share it here as well so hopefully everyone who lands on the question with this issue will not have to spend 30 hours blindfolded, resolving dex merging conflicts like I did.

Turns out that with new new version there is a few more options in the publish settings that needs to be set!

quoting RealPpTheBest s' answer

Go to player settings > Project Settings > Minify, in there, there will be an option of Release, set it to Gradle .

For some reason when choosing gradle build these two are not automatically toggled, and maybe in some cases they don't have to be. But setting minify to Grable (experimental) completely resolved all the build errors I was getting after updating unity.

EDIT: september-2019 - Solution above should still work, but:

I have lately been experimenting with choosing Proguard instead of the experimental Gradle minifier (can be selected in the dorpdown as well). When configured correctly proguard will also resolve your DEX limitation errors, and get rid of unused code and even compress your build size even more.

This post has a quite throughly detailed guide on how to enable and configure it. Keep in mind though, that the configuration will be unique to which dependencies you are using, so you will have to read up and do some custom configuration here most likely.

shareedit

edited Sep 26 '19 at 7:39

 

answered Jun 24 '19 at 15:46

Rasmus Puls

8996 silver badges19 bronze badges

 

[출처]

https://stackoverflow.com/questions/56623107/unity-gradle-build-error-while-merging-dex-archives/58012656#58012656

 

Unity gradle build - Error while merging dex archives

I'm trying to compile my project using "Build App Bundle (Google Play)" for the first time. However I am getting an error while merging dex archives. I believe it is due to some of my plugins are u...

stackoverflow.com

 

[참조]

https://forum.unity.com/threads/gradle-shenanagains.602599/

 

Gradle Shenanagains?

Honestly, I have no idea what's going wrong here. CommandInvokationFailure: Gradle build failed. C:\Program...

forum.unity.com

 

 
Posted by blueasa

댓글을 달아 주세요

[복사용 명령어]

keytool -exportcert -alias androiddebugkey -keystore C:\Users\{계정이름}\.android\myKeyStore | C:\Users\{계정이름}\openssl-0.9.8e_X64\bin\openssl sha1 -binary | C:\Users\{계정이름}\openssl-0.9.8e_X64\bin\openssl base64

 

 

[링크1] https://stickyny.tistory.com/62

 

[SO] 페이스북 연동을 위한 Hash Key 등록

3번째? 4번째 등록인 것 같다. 할 때마다 복잡하고 어렵다. APK를 배포하는 PC에 이 작업이 되어 있어야 한다. 1. 개발자 페이스북에 앱 추가하기 https://developers.facebook.com/apps/ URL에 접속해서 새 앱을..

stickyny.tistory.com

[링크2] https://mytalkhome.tistory.com/658

 

[Android] FaceBook Key Hash생성하기( 디버그 / 배표용 사인키 )

Facebook SDK를 사용하기 위해서는 Key Hash가 필요합니다 Android는 개발시 키를 2개를 사용하는데요, 개발시 사용되는 디버그키 , 실제 배포에 사용되는 키 입니다. 어차피 둘다 쓰는거니까 둘다 생성해서 등록..

mytalkhome.tistory.com

[링크3]

https://velog.io/@apocaris/Facebook-API-%EB%93%B1%EB%A1%9D%EC%9D%84-%EC%9C%84%ED%95%9C-Hash-Key-%EC%83%9D%EC%84%B1-72jvvt8bwd

 

Facebook API 등록을 위한 Hash Key 생성

java 설치 2. openssl 설치 링크로 이동하여 (다운로드) 윈도우 버전에 맞게 설치 프로그램을 받는다. 받고 압축을 풀고 임의의 위치에 옮긴다. ( 작성자는 C:\Users\계정 위치에 옮겼음 ) 3. cmd 를 열고 Java 가 설치된 경로로 이동. ( C:\Program Files\Java\jdk1.8.0211\bin ) 4. 다음의...

velog.io

 

Posted by blueasa

댓글을 달아 주세요

OS : Windows7 64bit

Unity : 2018.4.13f1

Firebase : 6.9.0


Generation of the Firebase Android resource file google-services.xml from Assets/Firebase/google-services.json failed.
If you have not included a valid Firebase Android resources in your app it will fail to initialize.
"C:\Project\git\ProjectName\Assets\Firebase\Editor\generate_xml_from_google_services_json.exe" -i "Assets/Firebase/google-services.json" -l

Traceback (most recent call last):
  File "", line 446, in 
  File "", line 289, in main
  File "", line 228, in argv_as_unicode_win32
AttributeError: 'module' object has no attribute 'wintypes'
generate_xml_from_google_services_json returned -1


Firebase 6.9.0을 유니티에 Import하고 위와 같은 에러를 보게 됐다.

결론적으로 wintypes attribute가 없다는 말인데 저게 뭔지 몰라서 한참 찾아 헤메다가

아래 링크에서 답을 찾았다.

 

[해결방법] 원본 (https://github.com/firebase/quickstart-unity/issues/540)

[해결방법] Detail (https://github.com/firebase/quickstart-unity/issues/540)

 

결론적으로 Firebase 6.9.0이 Windows7을 제대로 지원하지 않는 것 같다.

그래서 generate_xml_from_google_services_json.exe 파일을 다시 컴파일하는 작업을 위해서 설명하고 있다.

Python 2.7이 필요한데, Python 2.7.9 이상을 설치해야 pip가 Python에 기본적으로 들어 있다.

나는 아래 링크의 2.7.17을 깔았다.

 

[Python 2.7.17 다운로드] https://www.python.org/downloads/release/python-2717/

 

해결방법 Detail 설명대로 다하고나니 이제 에러가 뜨지 않는다.

 

 

P.s. Windows7 지원 종료가 되면서 여기저기 다른 곳에서도 지원을 종료하면서 개발에 피해가 오고 있는 걸 체감하고 있다.

    현재 피해 당하고 있는 건 SourceTree와 Firebase..-_-

 

 
Posted by blueasa

댓글을 달아 주세요